summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-26 10:13:35 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-26 10:31:58 +0100
commitd979197eaf10883e02c53b87f8e0d14bf254c525 (patch)
treeaf3cf8411827231d6ca48c119f532c3071e1fbb2
parentca133a7c4d8bf07618b17a614b872fb8538da77b (diff)
downloadguix-d979197eaf10883e02c53b87f8e0d14bf254c525.tar.gz
gnu: Fix guile-for-guile-emacs builder.
I think this broke in c4c08775a820868059b59c68d4dfd6be0c9d9010.

* gnu/packages/guile.scm (guile-for-guile-emacs)[arguments]: Switch to gexp
for phases.
-rw-r--r--gnu/packages/guile.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 1d36e3ee2a..414aafaf26 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -603,8 +603,8 @@ GNU@tie{}Guile.  Use the @code{(ice-9 readline)} module and call its
                   "1l7ik4q4zk7vq4m3gnwizc0b64b1mdr31hxqlzxs94xaf2lvi7s2"))))
       (arguments
        (substitute-keyword-arguments (package-arguments guile-2.2)
-         ((#:phases phases '%standard-phases)
-          `(modify-phases ,phases
+         ((#:phases phases)
+          #~(modify-phases #$phases
              (replace 'bootstrap
                (lambda _
                  ;; Disable broken tests.
@@ -617,8 +617,7 @@ GNU@tie{}Guile.  Use the @code{(ice-9 readline)} module and call its
                     (string-append "#;" m)))
 
                  (patch-shebang "build-aux/git-version-gen")
-                 (invoke "sh" "autogen.sh")
-                 #t))))))
+                 (invoke "sh" "autogen.sh")))))))
       (native-inputs
        (modify-inputs (package-native-inputs guile-2.2)
          (prepend autoconf