summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-06 23:10:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-06 23:10:36 -0400
commitd9ef50b3bc41be80f93ba6a86a911f7c68ab5ca6 (patch)
treee8aade3111bd96b70645b4c332bd41ffbd5f3d3a
parentbdc0c20cab77a25d260345a79ee0611c7e06e8ce (diff)
downloadguix-d9ef50b3bc41be80f93ba6a86a911f7c68ab5ca6.tar.gz
gnu: tegola: Fix build.
* gnu/packages/geo.scm (tegola)[arguments]: Adapt the "unpack-path" for the new
unpack phase.
* gnu/packages/geo.scm (tegola)[phases]{set-version}: Update the directory path.
{rename-import}: Remove phase.
-rw-r--r--gnu/packages/geo.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c8d149a7a2..94f2cf0cfb 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -668,21 +668,15 @@ extension.")
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/go-spatial/tegola/cmd/tegola"
-       #:unpack-path "github.com/go-spatial"
+       #:unpack-path "github.com/go-spatial/tegola"
        #:phases
        (modify-phases %standard-phases
          (add-before 'build 'set-version
            (lambda _
-             (with-directory-excursion
-               (string-append "src/github.com/go-spatial/tegola-" ,version)
+             (with-directory-excursion "src/github.com/go-spatial/tegola"
                (substitute* '("cmd/tegola/cmd/root.go"
                               "cmd/tegola_lambda/main.go")
                  (("version not set") ,version)))
-             #t))
-         (add-before 'build 'rename-import
-           (lambda _
-             (rename-file (string-append "src/github.com/go-spatial/tegola-" ,version)
-                          "src/github.com/go-spatial/tegola")
              #t)))))
     (home-page "http://tegola.io")
     (synopsis "Vector tile server for maps")