summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-03-29 17:46:36 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:41 +0200
commitdbb5650682751b71050d5ffd3071e78a5a8d1406 (patch)
tree37580b616492bb926a1dd58f2c444f7d3672a0f9
parent7c7ca0b62579838e3929e808a9b475ecc59f1515 (diff)
downloadguix-dbb5650682751b71050d5ffd3071e78a5a8d1406.tar.gz
gnu: bandage: Do not yet use the 'imagemagick/stable' variant.
Once <https://issues.guix.gnu.org/47475> (‘Closure of bandage is way too
large’) has been fixed, the variant will probably be usable.

* gnu/packages/bioinformatics.scm (bandage):
[arguments]<#:disallowed-references>: Once the issue
has been fixed, prevent the imagemagick/stable package from ending up in the
closure.
[native-inputs]: Note that 'imagemagick/stable' cannot be used yet.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: Ie13100eb424b14971055ff91db49bc7029cb6168
-rw-r--r--gnu/packages/bioinformatics.scm46
1 files changed, 26 insertions, 20 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9f39012ee8..4653360792 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17169,29 +17169,35 @@ Thus the per-base error rate is similar to the raw input reads.")
         (base32 "1bbsn5f5x8wlspg4pbibqz6m5vin8c19nl224f3z3km0pkc97rwv"))))
     (build-system qt-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda _
-             (invoke "qmake" "Bandage.pro")))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (substitute* "tests/bandage_command_line_tests.sh"
-                 (("^bandagepath=.*")
-                  (string-append "bandagepath=" (getcwd) "/Bandage\n")))
-               (with-directory-excursion "tests"
-                 (setenv "XDG_RUNTIME_DIR" (getcwd))
-                 (invoke "./bandage_command_line_tests.sh")))
-             #t))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (install-file "Bandage" (string-append out "/bin"))
-               #t))))))
+     (list
+      ;; TODO: Once <https://issues.guix.gnu.org/47475> is fixed,
+      ;; consider uncommenting the following:
+      ;;
+      ;; Prevent the (rarely updated) imagemagick/stable package from
+      ;; ending up in the closure.
+      ;; #:disallowed-references (list imagemagick/stable)
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'configure
+            (lambda _
+              (invoke "qmake" "Bandage.pro")))
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (substitute* "tests/bandage_command_line_tests.sh"
+                  (("^bandagepath=.*")
+                   (string-append "bandagepath=" (getcwd) "/Bandage\n")))
+                (with-directory-excursion "tests"
+                  (setenv "XDG_RUNTIME_DIR" (getcwd))
+                  (invoke "./bandage_command_line_tests.sh")))))
+          (replace 'install
+            (lambda _
+              (install-file "Bandage" (string-append #$output "/bin")))))))
     (inputs
      (list qtbase-5 qtsvg-5))
     (native-inputs
+     ;; imagemagick/stable cannot be used here, as it will end up in
+     ;; the closure.  See <https://issues.guix.gnu.org/47475>.
      (list imagemagick))
     (home-page "https://rrwick.github.io/Bandage/")
     (synopsis