summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-24 14:18:08 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:09:27 +0100
commitdc0a6dc61b269861fc21efa78af56207f662ee13 (patch)
treeb3baada5ed8be2470d68b081d721238b322d0e5e
parent1ff5aef15c855588deac2b3e834ee1479cc26083 (diff)
downloadguix-dc0a6dc61b269861fc21efa78af56207f662ee13.tar.gz
gnu: Remove ocaml4.07-core.
* gnu/packages/ocaml.scm (ocaml4.07-core): Remove variable.

Change-Id: Ie1e593746061506133e2e344e8c5021ad77f6820
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5058201eb0..9a437f2dc0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8271,35 +8271,6 @@ standard library that was developed by Jane Street.")
     ;; by OCaml's license for consortium members (see THIRD-PARTY.txt).
     (license license:expat)))
 
-(define-public ocaml4.07-core
-  (package-with-ocaml4.07
-    (package
-      (inherit ocaml-core)
-      (version "0.11.3")
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/janestreet/core")
-                       (commit (string-append "v" version))))
-                (file-name (git-file-name "ocaml4.07-core" version))
-                (sha256
-                 (base32
-                  "0pzl8n09z4f3i7z2wq4cjxfqrr8mj6xcdp7rbg0nxap2zdhjgvrq"))))
-      (propagated-inputs
-        (list ocaml-base
-              ocaml4.07-configurator
-              ocaml-core-kernel
-              ocaml-ppx-assert
-              ocaml-ppx-jane
-              ocaml-sexplib
-              ocaml-spawn
-              ocaml-stdio
-              ocaml-migrate-parsetree
-              ocaml-ppxlib))
-      ;; Also contains parts of OCaml, relicensed to asl2.0, as permitted
-      ;; by OCaml's license for consortium members (see THIRD-PARTY.txt).
-      (license license:asl2.0))))
-
 (define-public ocaml-int-repr
   (package
     (name "ocaml-int-repr")