summary refs log tree commit diff
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2023-04-21 21:46:12 +0000
committerAndreas Enge <andreas@enge.fr>2023-04-22 22:24:08 +0200
commitdcf2de77e195c7bce14006f69762396550d3630e (patch)
tree9f57cedced64b97480d073ec341d4a5511411dd7
parentc1fb1ac45b26491f51e669f419c75fa6eb599d88 (diff)
downloadguix-dcf2de77e195c7bce14006f69762396550d3630e.tar.gz
gnu: python-aenum: Update to 3.1.12.
* gnu/packages/python-xyz.scm (python-aenum): Update to 3.1.12.
[source]: Add snippet to delete Python 2 specific files.

Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10b28f0888..c5da7b1dd5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2407,13 +2407,18 @@ language.  It aims to be fast.")
 (define-public python-aenum
   (package
     (name "python-aenum")
-    (version "2.2.4")
+    (version "3.1.12")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "aenum" version))
        (sha256
-        (base32 "0r1812bjm72x73pl7y4yhffr4zbdjgxa08avsy4b3di0pqgqv0l1"))))
+        (base32 "1w1ffkcxgnimi5w8802qk6w2qxz9k8hpvsg6yy2zi08ahs8iqlry"))
+       (modules '((guix build utils)))
+       (snippet
+        ;; Delete the Python 2 specific files which won't compile
+        ;; in Python 3.
+        '(for-each delete-file (find-files "." "_py2.py$")))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases