summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 00:07:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:56 +0200
commitddcf6c378c401fc17b73f2833296cd1f95106158 (patch)
tree49872ea2cd119b552b5fdd8d0454d8a93f56b745
parent52c20ceb755842c6ba9c2ec0b8afc7ab699f461e (diff)
downloadguix-ddcf6c378c401fc17b73f2833296cd1f95106158.tar.gz
gnu: Add texlive-collection-langgerman.
* gnu/packages/tex.scm (texlive-collection-langgerman): New variable.
-rw-r--r--gnu/packages/tex.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4bdecd379c..5e9c1832ca 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33549,6 +33549,62 @@ simply on the size of the support.")
      "This collection provides support packages for French and Basque.")
     (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
+(define-public texlive-collection-langgerman
+  (package
+    (name "texlive-collection-langgerman")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs
+     (list texlive-apalike-german
+           texlive-babel-german
+           texlive-bibleref-german
+           texlive-booktabs-de
+           texlive-collection-basic
+           texlive-csquotes-de
+           texlive-dhua
+           texlive-dtk-bibliography
+           texlive-etdipa
+           texlive-etoolbox-de
+           texlive-fifinddo-info
+           texlive-german
+           texlive-germbib
+           texlive-germkorr
+           texlive-hausarbeit-jura
+           texlive-hyphen-complete
+           texlive-koma-script-examples
+           texlive-l2picfaq
+           texlive-l2tabu
+           texlive-latexcheat-de
+           texlive-lshort-german
+           texlive-lualatex-doc-de
+           texlive-microtype-de
+           texlive-milog
+           texlive-quran-de
+           texlive-r-und-s
+           texlive-schulmathematik
+           texlive-templates-fenn
+           texlive-templates-sommer
+           texlive-termcal-de
+           texlive-tipa-de
+           texlive-translation-arsclassica-de
+           texlive-translation-biblatex-de
+           texlive-translation-chemsym-de
+           texlive-translation-ecv-de
+           texlive-translation-enumitem-de
+           texlive-translation-europecv-de
+           texlive-translation-filecontents-de
+           texlive-translation-moreverb-de
+           texlive-udesoftec
+           texlive-uhrzeit
+           texlive-umlaute
+           texlive-voss-mathcol))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Support for German")
+    (description "This collection provides support packages for German.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
 (define-public texlive-collection-latex
   (package
     (name "texlive-collection-latex")