summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 11:56:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:04 +0200
commitde570ecd7e7c74157f0b6140b546418650184384 (patch)
tree5c6b028daa0fa155fa353686bb000f1d6478f41c
parent7015018cdabdd4338ab97b604416e594a6088ce4 (diff)
downloadguix-de570ecd7e7c74157f0b6140b546418650184384.tar.gz
gnu: Add texlive-vlna.
* gnu/packages/tex.scm (texlive-vlna): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 35a9ffb36b..161e85e228 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6908,6 +6908,26 @@ settings.")
     (description "This package provides MetaPost macros for Venn diagrams.")
     (license license:lppl)))
 
+(define-public texlive-vlna
+  (package
+    (name "texlive-vlna")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/vlna.1"
+                   "doc/man/man1/vlna.man1.pdf" "doc/vlna/")
+             (base32
+              "0nfb7mj6y9d4n89z59ppi96grfylwky97mxcv9rjflr5kpqlpga2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/vlna")
+    (synopsis "Add @samp{~} after non-syllabic preposition, for Czech/Slovak")
+    (description
+     "This package provides a preprocessor for TeX source implementing the
+Czech/Slovak typographical rule forbidding a non-syllabic preposition alone at
+the end of a line.")
+    (license license:knuth)))
+
 (define-public texlive-witharrows
   (package
     (name "texlive-witharrows")