summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:25:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:20 +0200
commitde802a7d269885b8df7314273e9b881a5b913de3 (patch)
treef19bff1d4cc085177b0f4743244035d10115d729
parent7a52c1a4fe05b4e005a12506a50afed8c3bfd8c5 (diff)
downloadguix-de802a7d269885b8df7314273e9b881a5b913de3.tar.gz
gnu: Add texlive-bjfuthesis.
* gnu/packages/tex.scm (texlive-bjfuthesis): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c52c8256b2..7f8adb225c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6824,6 +6824,26 @@ the Bitter family of fonts.  Bitter is a contemporary slab-serif typeface for
 text.  There are regular and bold weights and an italic, but no bold italic.")
     (license (list license:lppl license:silofl1.1))))
 
+(define-public texlive-bjfuthesis
+  (package
+    (name "texlive-bjfuthesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/bjfuthesis/"
+                   "tex/latex/bjfuthesis/")
+             (base32
+              "0qhb9kighs4ljmnn94qaihpllhwvmi76j3p8yylyjw2hzip102wr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/bjfuthesis")
+    (synopsis "Thesis class for Beijing Forestry University")
+    (description
+     "This is a class file for producing dissertations and theses according to
+the @acronym{BJFU, Beijing Forestry University} guidelines for undergraduate
+theses and dissertations.")
+    (license license:gpl3)))
+
 (define-public texlive-blacklettert1
   (package
     (name "texlive-blacklettert1")