summary refs log tree commit diff
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2022-07-24 19:34:31 +0800
committerLudovic Courtès <ludo@gnu.org>2022-08-01 14:08:08 +0200
commitdee64d4776e6d97f10b71d3484dff5f350af63c3 (patch)
treed3dc6c75ddf54403bf178e094da53742f4edc65b
parent49000523d22e31334525fedb9a8913dd8f2e21a0 (diff)
downloadguix-dee64d4776e6d97f10b71d3484dff5f350af63c3.tar.gz
gnu: guile-lens: Fix build.
* gnu/packages/guile-xyz.scm (guile-lens)
[phases]{run-hall}: replace "dist" to "build-system".

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0717acf83b..dd28e38a20 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -43,6 +43,7 @@
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3944,7 +3945,7 @@ as signed sessions, multipart message support, etc.")
            (add-after 'unpack 'run-hall
              (lambda _
                (setenv "HOME" "/tmp")   ; for ~/.hall
-               (invoke "hall" "dist" "-x"))))))
+               (invoke "hall" "build-system" "-x"))))))
       (native-inputs
        (list autoconf
              automake