summary refs log tree commit diff
diff options
context:
space:
mode:
authorSiniša Biđin <sinisa@bidin.eu>2015-08-18 16:19:11 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-28 11:00:03 +0200
commitdf1db7672d3c9d071057fadc4f31a9760f14df46 (patch)
tree9ea4ba19f774824304a37caaddff33e41eb36ce7
parent7bce9fa5f380fe97973363b501dd330d4d50a3da (diff)
downloadguix-df1db7672d3c9d071057fadc4f31a9760f14df46.tar.gz
gnu: Add cabal-install.
* gnu/packages/haskell.scm (cabal-install): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4b2b627561..34cad87b4b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -426,6 +427,37 @@ Writer monad), where list append quickly becomes too expensive.")
 versions of GHC (i.e., < 6.10).")
     (license bsd-3)))
 
+(define-public cabal-install
+ (package
+  (name "cabal-install")
+   (version "1.18.1.0")
+   (source
+    (origin
+     (method url-fetch)
+      (uri (string-append
+            "http://hackage.haskell.org/package/cabal-install/cabal-install-"
+            version
+            ".tar.gz"))
+      (sha256
+       (base32 "1r1shhvnpgxf91rmbv3wa1rkd24plbgr6bpz3aj80ir0z3zbdayn"))))
+   (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
+   (build-system haskell-build-system)
+   (propagated-inputs
+    `(("ghc-http" ,ghc-http)
+      ("ghc-mtl" ,ghc-mtl)
+      ("ghc-network-uri" ,ghc-network-uri)
+      ("ghc-network" ,ghc-network)
+      ("ghc-random" ,ghc-random)
+      ("ghc-stm" ,ghc-stm)
+      ("ghc-zlib" ,ghc-zlib)))
+   (home-page "http://www.haskell.org/cabal/")
+   (synopsis "Command-line interface for Cabal and Hackage")
+   (description
+    "The cabal command-line program simplifies the process of managing
+Haskell software by automating the fetching, configuration, compilation and
+installation of Haskell libraries and programs.")
+   (license bsd-3)))
+
 (define-public ghc-mtl
   (package
     (name "ghc-mtl")