summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-04 00:11:06 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-04 00:11:06 +0200
commitdfba405510e4f81d1e05ac647afdd28ca04c8a56 (patch)
tree62051df59feb760604e3dfbdc379853252a4d421
parent458b2a76588487543e6b80413a5717c6a75d4df3 (diff)
downloadguix-dfba405510e4f81d1e05ac647afdd28ca04c8a56.tar.gz
gnu: xorg: Add xcb-util-image.
* gnu/packages/xorg.scm (xcb-util-image): New variable.
-rw-r--r--gnu/packages/xorg.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 0f18a30b4f..5bb0a97528 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4495,6 +4495,37 @@ event: Some utilities that have little to do with events any more.")
     (license license:x11)))
 
 
+(define-public xcb-util-image
+  (package
+    (name "xcb-util-image")
+    (version "0.3.9")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "http://xcb.freedesktop.org/dist/" name "-"
+                                 version ".tar.bz2"))
+             (sha256
+              (base32
+               "1pr1l1nkg197gyl9d0fpwmn72jqpxjfgn9y13q4gawg1m873qnnk"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+     `(("libxcb" ,libxcb)))
+    (inputs
+     `(("pkg-config" ,pkg-config)
+       ("xcb-util" ,xcb-util)))
+    (home-page "http://cgit.freedesktop.org/xcb/util-image/")
+    (synopsis "XCB port of Xlib's XImage and XShmImage")
+    (description "The XCB util module provides a number of libraries which
+    sit on top of libxcb, the core X protocol library, and some of the
+    extension libraries.  These experimental libraries provide convenience
+functions and interfaces which make the raw X protocol more usable.  Some of
+the libraries also provide client-side code which is not strictly part of
+the X protocol but which has traditionally been provided by Xlib.
+
+The XCB util-image module provides the following library:
+image: Port of Xlib's XImage and XShmImage functions.")
+    (license license:x11)))
+
+
 (define-public xcb-util-wm
   (package
     (name "xcb-util-wm")