summary refs log tree commit diff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2023-01-17 18:45:07 -0700
committerChristopher Baines <mail@cbaines.net>2023-02-07 00:05:54 +0100
commitdfd1bcb3a61edc20f3954a525282ae8f1644a75b (patch)
tree4ea37ef72c81ac45f7e96b8f82a61247c9e5850a
parent90a2ef549b9e6d4f8eae8f07d7c070f29f9b8bb6 (diff)
downloadguix-dfd1bcb3a61edc20f3954a525282ae8f1644a75b.tar.gz
gnu: go-honnef-co-go-tools: Update to 0.3.3.
* gnu/packages/golang.scm (go-honnef-co-go-tools): Update to 0.3.3.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b95f046178..026ee25be1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10052,27 +10052,26 @@ tools with similar semantics.")
 (define-public go-honnef-co-go-tools
   (package
     (name "go-honnef-co-go-tools")
-    (version "0.1.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/dominikh/go-tools")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "17li8jbw3cpn59kpcl3j3r2an4wkx3fc81xn0j4xgbjpkxh9493n"))))
+    (version "0.3.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dominikh/go-tools")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "099z04v7vvwwglnps315s9fmal68xvzlc1g8m26iqi980grbwn32"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "honnef.co/go/tools"
        #:tests? #f
        ;; Source-only package
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'build))))
-    (propagated-inputs
-     (list go-golang-org-x-tools go-github-com-kisielk-gotool
-           go-github-com-burntsushi-toml))
+       #:phases (modify-phases %standard-phases
+                  (delete 'build))))
+    (propagated-inputs (list go-golang-org-x-exp go-golang-org-x-tools
+                             go-golang-org-x-mod go-github-com-kisielk-gotool
+                             go-github-com-burntsushi-toml))
     (home-page "https://honnef.co/go/tools")
     (synopsis "Staticcheck advanced Go linter")
     (description