summary refs log tree commit diff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-08-20 14:56:30 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-20 19:27:32 +0300
commitdfe4d0134b8527bc931d2516b5feb09254fa7676 (patch)
tree7f2a1ef413dc8c8c52594a9f791401b05965a465
parentc00ebfd6d7f8cf58d5972c3c8b3ea504879c90e9 (diff)
downloadguix-dfe4d0134b8527bc931d2516b5feb09254fa7676.tar.gz
gnu: emacs-perspective: Update to 2.10.
* gnu/packages/emacs-xyz.scm (emacs-perspective): Update to 2.10.
(arguments): Run tests suite.

Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7c4b9d25c4..980532ef46 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6460,7 +6460,7 @@ regexp that matches all known keywords.")
 (define-public emacs-perspective
   (package
     (name "emacs-perspective")
-    (version "2.9")
+    (version "2.10")
     (source
      (origin
        (method git-fetch)
@@ -6470,8 +6470,13 @@ regexp that matches all known keywords.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1hmbczw3b7k2xdqcy5p3xnf2781gjw6bqqcwc5r9myg6b8p3pr7m"))))
+         "1xfcm69nd6f9chwlqfz5vd8nnyl5mwharxjrn1m515568dqrk62x"))))
     (build-system emacs-build-system)
+    (arguments
+     `(#:tests? #t
+       #:test-command '("emacs" "-Q" "-batch" "-L" "."
+                        "-l" "test/test-perspective.el"
+                        "-f" "ert-run-tests-batch-and-exit")))
     (home-page "https://github.com/nex3/perspective-el")
     (synopsis "Switch between named \"perspectives\"")
     (description