summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 21:41:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:08 +0200
commite0268ff2e404ca963f25d89fb52178768da0b856 (patch)
tree2771b15886d5dba4f922eddcf48bd800052e9c1c
parentd3c67e1b45865b96122ba249280a7b61ce1850d4 (diff)
downloadguix-e0268ff2e404ca963f25d89fb52178768da0b856.tar.gz
gnu: Add r-getoptlong.
* gnu/packages/cran.scm (r-getoptlong): New variable.
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b2502e1826..abdff54db9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22,7 +22,9 @@
   #:use-module (guix download)
   #:use-module (guix utils)
   #:use-module (guix build-system r)
-  #:use-module (gnu packages statistics))
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages statistics)
+  #:use-module (gnu packages web))
 
 (define-public r-colorspace
   (package
@@ -338,3 +340,29 @@ type, etc of its branches, nodes and labels) and visually and statistically
 compare different dendrograms to one another.")
     ;; Any of these versions
     (license (list license:gpl2 license:gpl3))))
+
+(define-public r-getoptlong
+  (package
+    (name "r-getoptlong")
+    (version "0.1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "GetoptLong" version))
+       (sha256
+        (base32
+         "1d98gcvlvp9nz5lbnzr0kkpc2hbkx74hlhrnybqhg1gdwc3g09pm"))))
+    (properties `((upstream-name . "GetoptLong")))
+    (build-system r-build-system)
+    (inputs
+     `(("perl" ,perl)))
+    (propagated-inputs
+     `(("r-globaloptions" ,r-globaloptions)
+       ("r-rjson" ,r-rjson)))
+    (home-page "https://github.com/jokergoo/GetoptLong")
+    (synopsis "Parsing command-line arguments and variable interpolation")
+    (description
+     "This is yet another command-line argument parser which wraps the
+powerful Perl module @code{Getopt::Long} and with some adaptation for easier
+use in R.  It also provides a simple way for variable interpolation in R.")
+    (license license:gpl2+)))