summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-25 08:16:11 +0800
committerAndreas Enge <andreas@enge.fr>2023-07-26 13:28:59 +0200
commite05dcecd0df49a397aba49585a626cae16a6306c (patch)
tree62bd23ebc4fcc7eddd941064ea9ee387c96f512e
parent707682ac75a81f41a478c2c51672ca49b98fa6eb (diff)
downloadguix-e05dcecd0df49a397aba49585a626cae16a6306c.tar.gz
gnu: python-shiboken-6: Remove inherited workaround.
Fixes: <https://issues.guix.gnu.org/64803>.

* gnu/packages/qt.scm (python-shiboken-6)[arguments]<#:phases>: Delete
'workaround-importlib-error, which breaks the build.

Reported-by: Formbi <formbi@protonmail.com>
Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/qt.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a79338f84e..e8654eee44 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4005,6 +4005,7 @@ color-related widgets.")
      (substitute-keyword-arguments (package-arguments python-shiboken-2)
        ((#:phases p)
         #~(modify-phases #$p
+            (delete 'workaround-importlib-error)
             (replace 'use-shiboken-dir-only
               (lambda _ (chdir "sources/shiboken6")))))
        ((#:configure-flags flags)