summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 12:47:42 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:24 +0300
commite0f1789d2b40eead6d222523db9be1f59f2bb066 (patch)
tree6d143a6658b1eba8e1e138b42b9ba28eae0e3a75
parentfd2a3046a86a134bb81a8b6a8080908c7a967ed8 (diff)
downloadguix-e0f1789d2b40eead6d222523db9be1f59f2bb066.tar.gz
gnu: Add go-github-com-go-git-go-git-fixtures.
* gnu/packages/golang.scm (go-github-com-go-git-go-git-fixtures): New variable.
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4d10102688..1af17237da 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5254,3 +5254,32 @@ ssh-agent process using the sample server. ")
       (description "This package provides a Go library to extract tgz files to
 temporal directories.")
       (license license:expat))))
+
+(define-public go-github-com-go-git-go-git-fixtures
+  (package
+    (name "go-github-com-go-git-go-git-fixtures")
+    (version "4.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-git/go-git-fixtures")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "002yb1s2mxq2xijkl39ip1iyc3l52k23ikyi9ijfl4bgqxy79ljg"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/go-git/go-git-fixtures/v4"
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'reset-gzip-timestamps))))
+    (native-inputs
+     `(("go-github-com-alcortesm-tgz" ,go-github-com-alcortesm-tgz)
+       ("go-github-com-go-git-go-billy" ,go-github-com-go-git-go-billy)
+       ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+       ("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+    (home-page "https://github.com/go-git/go-git-fixtures/")
+    (synopsis "Fixtures used by @code{go-git}")
+    (description "This package provides fixtures used by @code{go-git}.")
+    (license license:asl2.0)))