summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2024-05-18 13:39:38 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-06-24 08:51:44 -0400
commite121ecccdc5fe3b7422b85db9c3451e29cbac0d1 (patch)
tree43de4c8502997bd2e24077c1d0d2e71aafbf5e89
parent26f46cfd2a1442ebada5178dccb1cc5a5bf95feb (diff)
downloadguix-e121ecccdc5fe3b7422b85db9c3451e29cbac0d1.tar.gz
gnu: opensc: Switch to new package style.
* gnu/packages/security-token.scm (opensc)[arguments]: Use g-exps.

Change-Id: I3e59323deb804ba98669d51771ccfa05a92723e3
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/security-token.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index e569d071b8..da2957fe7a 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -366,20 +366,19 @@ website for more information about Yubico and the YubiKey.")
                 "0yxk97aj29pybvya6r9ix9xh00hdzcfrc2lcns4vb3kwpplamjr3"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; By setting an absolute path here, we arrange for OpenSC to
-         ;; successfully dlopen libpcsclite.so.1 by default.  The user can
-         ;; still override this if they want to, by specifying a custom OpenSC
-         ;; configuration file at runtime.
-         (add-after 'unpack 'set-default-libpcsclite.so.1-path
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((libpcsclite (search-input-file inputs
-                                                   "/lib/libpcsclite.so.1")))
-               (substitute* "configure"
-                 (("DEFAULT_PCSC_PROVIDER=\"libpcsclite\\.so\\.1\"")
-                  (string-append
-                   "DEFAULT_PCSC_PROVIDER=\"" libpcsclite "\"")))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; By setting an absolute path here, we arrange for OpenSC to
+          ;; successfully dlopen libpcsclite.so.1 by default.  The user can
+          ;; still override this if they want to, by specifying a custom OpenSC
+          ;; configuration file at runtime.
+          (add-after 'unpack 'set-default-libpcsclite.so.1-path
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((libpcsclite (search-input-file inputs "/lib/libpcsclite.so.1")))
+                (substitute* "configure"
+                  (("DEFAULT_PCSC_PROVIDER=\"libpcsclite\\.so\\.1\"")
+                   (string-append "DEFAULT_PCSC_PROVIDER=\"" libpcsclite "\"")))))))))
     (inputs
      (list readline openssl-1.1 pcsc-lite ccid))
     (native-inputs