summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-01 20:00:17 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 22:22:51 +0200
commite21e7b0b4f006f72baf514372d35dbc2790616bd (patch)
treea8a952d4150babfe6a2e5e6471fab975617b2b72
parentf22c65e019f8b8492a794993a9c5aa37743b9882 (diff)
downloadguix-e21e7b0b4f006f72baf514372d35dbc2790616bd.tar.gz
gnu: glade: gjs is a run-time dependency.
* gnu/packages/gnome.scm (glade3)[native-inputs]: Move GJS ...
[inputs]: ... here.
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cc9307470b..6aad3cec32 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3143,7 +3143,7 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
              (substitute* "meson_post_install.py"
                (("gtk-update-icon-cache") "true"))))
 
-         ,@(if (this-package-native-input "gjs")
+         ,@(if (this-package-input "gjs")
                '()
                '((add-after 'unpack 'skip-gjs-test
                    (lambda _
@@ -3170,7 +3170,13 @@ current/manpages/docbook.xsl")
              (system "Xvfb :1 &")
              (setenv "DISPLAY" ":1"))))))
     (inputs
-     (list gtk+ libxml2))
+     (append
+      ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
+      ;; dependency on other platforms (FIXME).
+      (if (target-x86-64?)
+          (list gjs)
+          '())
+      (list gtk+ libxml2)))
     (native-inputs
      `(("hicolor-icon-theme" ,hicolor-icon-theme)
        ("intltool" ,intltool)
@@ -3182,13 +3188,6 @@ current/manpages/docbook.xsl")
        ("python" ,python)
        ("python-pygobject" ,python-pygobject)
        ("gobject-introspection" ,gobject-introspection)
-
-       ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
-       ;; dependency on other platforms (FIXME).
-       ,@(if (target-x86-64?)
-             `(("gjs" ,gjs))
-             '())
-
        ("pkg-config" ,pkg-config)
        ("xorg-server" ,xorg-server-for-tests)))
     (home-page "https://glade.gnome.org")