summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-05-27 18:21:40 +0000
committerChristopher Baines <mail@cbaines.net>2023-06-12 19:41:17 +0100
commite2f25b79cbcafe0df350caaa5180ca2d542ff72d (patch)
treebe42300696e166926fd2892683f3d0d018c2c273
parent9c1697020912ac24ff6be7eb6591314fdb74fc07 (diff)
downloadguix-e2f25b79cbcafe0df350caaa5180ca2d542ff72d.tar.gz
gnu: python-absl-py: Update to 1.4.0.
* gnu/packages/python-xyz.scm (python-absl-py): Update to 1.4.0.
[arguments]: Remove 'patch-version-check phase.
[propagated-inputs]: Remove python-six.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 497b06a1c5..968a8e1be9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25473,26 +25473,15 @@ RFC 8265 and RFC 8266.")
 (define-public python-absl-py
   (package
     (name "python-absl-py")
-    (version "0.6.1")
+    (version "1.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "absl-py" version))
        (sha256
         (base32
-         "1mp9lk0b2qa37b7y6ak4lvf6ifw2ylyy6bkf9ik77md3j4xrwlc7"))))
+         "0ga3b0m8lfsv1m3260p83lhis52yvz3d42q8gip4gfj823849hnj"))))
     (build-system pyproject-build-system)
-    (arguments
-     (list
-      #:phases
-      '(modify-phases %standard-phases
-         (add-after 'unpack 'patch-version-check
-           (lambda _
-             ;; Python 3.10 is indeed more recent than Python 3.4.
-             (substitute* "setup.py"
-               ((" or py_version\\[0\\] == '3'.*") ":")))))))
-    (propagated-inputs
-     (list python-six))
     (home-page "https://github.com/abseil/abseil-py")
     (synopsis "Abseil Python common libraries")
     (description