summary refs log tree commit diff
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:43 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:21 +0200
commite2fde26c92daa81670fe26c656f915b1d7806844 (patch)
tree26d6fdccf5f17867ed32a91219edf5299818d79a
parent2229302df8c39c20d01512af1161f9e4b40951a1 (diff)
downloadguix-e2fde26c92daa81670fe26c656f915b1d7806844.tar.gz
gnu: Add ghc-constraints-extras.
* gnu/packages/haskell-xyz.scm (ghc-constraints-extras): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5dd9a7d9a7..98b068dcc6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2468,6 +2468,29 @@ They stopped crashing the compiler in GHC 7.6.  This package provides
 a vocabulary for working with them.")
     (license license:bsd-2)))
 
+(define-public ghc-constraints-extras
+  (package
+    (name "ghc-constraints-extras")
+    (version "0.4.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "constraints-extras" version))
+              (sha256
+               (base32
+                "1irf4kd7a5h1glczbc73c3590m58azn4s68nfrjfg1h96i7mjfgn"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "constraints-extras")))
+    (inputs (list ghc-constraints ghc-aeson))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "1fdabah3ilq9yf94916ml3c3rxgcgab1jhzl4mk1zgzsw78j53qf")))
+    (home-page "https://github.com/obsidiansystems/constraints-extras")
+    (synopsis "Utility package for constraints")
+    (description
+     "Convenience functions and TH for working with constraints.  See
+@file{README.md} for example usage.")
+    (license license:bsd-3)))
+
 (define-public ghc-contravariant
   (package
     (name "ghc-contravariant")