summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-06-27 00:29:29 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-06-30 00:07:55 +0200
commite31d7f44203595e6c1b14dfadc9064693f921bd0 (patch)
tree8390fc2beb117b77ae71440e73cbfe225fb4ce37
parentd889e6c4d9af68701be3e8a12bc377369d1c8625 (diff)
downloadguix-e31d7f44203595e6c1b14dfadc9064693f921bd0.tar.gz
gnu: Add python-pyflakes.
* gnu/packages/python.scm (python-pyflakes, python2-pyflakes): New variables.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0bcaf5df8e..cf9d3cad54 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3929,3 +3929,27 @@ PEP 8.")
 
 (define-public python2-pep8
   (package-with-python2 python-pep8))
+
+(define-public python-pyflakes
+  (package
+    (name "python-pyflakes")
+    (version "0.9.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/p/pyflakes/pyflakes-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "0pvawddspdq0y22dbraq5gld9qr6rwa7zhmpfhl2b7v9rqiiqs82"))))
+    (build-system python-build-system)
+    (inputs
+      `(("python-setuptools" ,python-setuptools)))
+    (home-page
+      "https://github.com/pyflakes/pyflakes")
+    (synopsis "Passive checker of Python programs")
+    (description
+      "Pyflakes statically checks Python source code for common errors.")
+    (license license:expat)))