summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-23 07:35:56 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-23 07:35:56 +0800
commite3cadebaf0a8560f6b74264541a1397bec2cf8d8 (patch)
tree0ca351ff921d9cef769675b5db89de8222d43bf4
parent0dec8f8c1356ca2305c9e4b913ad133ebc854adc (diff)
downloadguix-e3cadebaf0a8560f6b74264541a1397bec2cf8d8.tar.gz
gnu: Add xf86-input-libinput.
* gnu/packages/xorg.scm (xf86-input-libinput): New variable.
-rw-r--r--gnu/packages/xorg.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 998f0803fc..401c6dba04 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -45,7 +45,8 @@
   #:use-module (gnu packages python)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages ncurses)
-  #:use-module (gnu packages xdisorg))
+  #:use-module (gnu packages xdisorg)
+  #:use-module (gnu packages freedesktop))
 
 
 
@@ -2220,6 +2221,35 @@ devices, thus making direct access unnecessary.")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
 
+(define-public xf86-input-libinput
+  (package
+    (name "xf86-input-libinput")
+    (version "0.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://xorg/individual/driver/"
+                    name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0fm4vrkw7azipbnwvc2l18g65z77pllsznaajd8q3zpg9ycb0li1"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags
+       (list (string-append "--with-sdkdir="
+                            %output "/include/xorg"))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libinput" ,libinput)
+       ("xorg-server" ,xorg-server)))
+    (home-page "http://www.x.org/wiki/")
+    (synopsis "Xorg input driver")
+    (description
+     "This is an Xorg input driver based on libinput.  It therefore supports
+all input devices that libinput can handle, including most mice, keyboards,
+tablets and touchscreens.")
+    (license license:x11)))
 
 (define-public xf86-input-joystick
   (package