summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-26 22:00:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-27 02:56:17 +0200
commite3e74e40227bdf3e47077a5d32665f3e44bfa186 (patch)
treefc81bfb3d52c3426b1ccb845a291bbb26a8a3cfb
parentae9877fed35a3add9ce38eab524daca597c00b52 (diff)
downloadguix-e3e74e40227bdf3e47077a5d32665f3e44bfa186.tar.gz
gnu: python2-ndg-httpsclient: Fix build.
This might be a follow-up to a39cc016329f1f490ac7629fa81c9b686e7b0f4e
from 2016, which would be neat.

* gnu/packages/python-web.scm (python2-ndg-httpsclient)[arguments]: Use
SUBSTITUTE-KEYWORD-ARGUMENTS to still skip tests.
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 53a9d3c2f3..6e8d9ab954 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -44,6 +44,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system python)
+  #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -1024,7 +1025,9 @@ of the SSL peer.")
 (define-public python2-ndg-httpsclient
   (package (inherit python-ndg-httpsclient)
     (name "python2-ndg-httpsclient")
-    (arguments `(#:python ,python-2))
+    (arguments
+     (substitute-keyword-arguments (package-arguments python-ndg-httpsclient)
+       ((#:python _) python-2)))
     (propagated-inputs
      `(("python2-pyopenssl" ,python2-pyopenssl)))))