summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-10 14:54:11 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-11 15:48:05 -0500
commite55d07b134680ca952ee6e458ce34ff57ea3ec17 (patch)
tree517f5060cc0ffb0ffd1288e9764e279accee9bf6
parent9afa15ffee9985c9197450cf558c47453580269a (diff)
downloadguix-e55d07b134680ca952ee6e458ce34ff57ea3ec17.tar.gz
gnu: Add File-ShareDir-Install.
* gnu/packages/perl.scm (perl-file-sharedir-install): New variable.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9709c4b655..7dc3105b2e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -868,6 +868,26 @@ provided base directory and can return files (and/or directories if desired)
 matching a regular expression.")
     (home-page "http://search.cpan.org/~dopacki/File-List/")))
 
+(define-public perl-file-sharedir-install
+  (package
+    (name "perl-file-sharedir-install")
+    (version "0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/G/GW/GWYN/"
+                           "File-ShareDir-Install-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1xz60bi7x8755lq24rx7y1jkyk3icssn7s55z665mysdxhfzg2kh"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/File-ShareDir-Install")
+    (synopsis "Install shared files")
+    (description "File::ShareDir::Install allows you to install read-only data
+files from a distribution.  It is a companion module to File::ShareDir, which
+allows you to locate these files after installation.")
+    (license (package-license perl))))
+
 (define-public perl-file-temp
   (package
     (name "perl-file-temp")