summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-17 09:06:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:42 +0300
commite571fc2af87612f58871237a80e68d834704ab48 (patch)
treebadb76b8c448023bf45c4cc5f1007e6cb506e524
parent61e41cee149638ba5848fb879f4c626723beeed6 (diff)
downloadguix-e571fc2af87612f58871237a80e68d834704ab48.tar.gz
gnu: Remove rust-cbindgen-0.15.
* gnu/packages/rust-apps.scm (rust-cbindgen-0.15): Delete variable.
-rw-r--r--gnu/packages/rust-apps.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 2bb0aed01c..5ffb82896d 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1203,33 +1203,6 @@ rebase.")
        #:cargo-development-inputs
        (("rust-serial-test" ,rust-serial-test-0.5))))))
 
-(define-public rust-cbindgen-0.15
-  (package
-    (inherit rust-cbindgen)
-    (name "rust-cbindgen")
-    (version "0.15.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "cbindgen" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0dgf49zij9rxnf0lv4k5gcmx1mxcz16czkk6q63anz0xp8ds3xhx"))))
-    (arguments
-     `(#:tests? #false                  ;missing files
-       #:cargo-inputs
-       (("rust-clap" ,rust-clap-2)
-        ("rust-heck" ,rust-heck-0.3)
-        ("rust-indexmap" ,rust-indexmap-1)
-        ("rust-log" ,rust-log-0.4)
-        ("rust-proc-macro2" ,rust-proc-macro2-1)
-        ("rust-quote" ,rust-quote-1)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-syn" ,rust-syn-1)
-        ("rust-tempfile" ,rust-tempfile-3)
-        ("rust-toml" ,rust-toml-0.5))))))
-
 (define-public sniffglue
   (package
     (name "sniffglue")