summary refs log tree commit diff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2020-02-06 12:55:15 -0800
committerVagrant Cascadian <vagrant@debian.org>2020-02-06 13:14:13 -0800
commite68321a641d8bafd18386792f2b2ce9a57e54ce3 (patch)
treedd8a88aac4b63bada3aee2e635ab37070d23a47e
parentb1daba942eebf6cea1f9aab4a82027b20e29d11c (diff)
downloadguix-e68321a641d8bafd18386792f2b2ce9a57e54ce3.tar.gz
gnu: Add python-nose-random.
* gnu/packages/check (python-nose-random): New variable.
-rw-r--r--gnu/packages/check.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index f9eb350ff4..fa6575173f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2116,6 +2116,32 @@ JSON APIs with Behave.")
 (define-public python2-rednose
   (package-with-python2 python-rednose))
 
+(define-public python-nose-random
+  (package
+    (name "python-nose-random")
+    (version "1.0.0")
+    (source
+     (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/fzumstein/nose-random")
+            (commit version)))
+      (file-name (git-file-name name version))
+      (sha256
+       (base32
+        "1dvip61r2frjv35mv6mmfjc07402z73pjbndfp3mhxyjn2zhksw2"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page "https://github.com/fzumstein/nose-random")
+    (synopsis "Nose plugin to facilitate randomized unit testing with
+Python")
+    (description "Python nose-random is designed to facilitate
+Monte-Carlo style unit testing.  The idea is to improve testing by
+running your code against a large number of randomly generated input
+scenarios.")
+    (license license:expat)))
+
 (define-public python-nose-randomly
   (package
     (name "python-nose-randomly")