summary refs log tree commit diff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-01-03 10:38:07 +0100
committerRutger Helling <rhelling@mykolab.com>2018-01-03 10:40:59 +0100
commite6b94a0247f701c8f365a9a339f0c187d607f975 (patch)
tree8172e0ba176a363063a78f96ad4c9ad68b804ff8
parent036f35772c5ffc2ede5bf6a47422ac2c349135f4 (diff)
downloadguix-e6b94a0247f701c8f365a9a339f0c187d607f975.tar.gz
gnu: wine64-staging: Fix arguments.
* gnu/packages/wine.scm (wine64-staging)[arguments]: Use new
'copy-wine32-binaries and 'copy-wine32-manpage phases instead of
'copy-wine32-files phase.
-rw-r--r--gnu/packages/wine.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 4ebc23f5e0..78f68385e0 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -269,23 +269,25 @@ integrated into the main branch.")
              (string-append "libdir=" %output "/lib/wine64"))
        #:phases
        (modify-phases %standard-phases
-         (add-after 'install 'copy-wine32-files
+         (add-after 'install 'copy-wine32-binaries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((wine32 (assoc-ref %build-inputs "wine"))
+                    (out (assoc-ref %outputs "out")))
+               ;; Copy the 32-bit binaries needed for WoW64.
+               (copy-file (string-append wine32 "/bin/wine")
+                          (string-append out "/bin/wine"))
+               (copy-file (string-append wine32 "/bin/wine-preloader")
+                          (string-append out "/bin/wine-preloader"))
+               #t)))
+         (add-after 'compress-documentation 'copy-wine32-manpage
            (lambda* (#:key outputs #:allow-other-keys)
-             ;; Copy the 32-bit binaries needed for WoW64.
-             (copy-file (string-append (assoc-ref %build-inputs "wine-staging")
-                                       "/bin/wine") (string-append (assoc-ref
-                                       %outputs "out") "/bin/wine"))
-             (copy-file (string-append (assoc-ref %build-inputs "wine-staging")
-                                       "/bin/wine-preloader") (string-append
-                                       (assoc-ref %outputs "out")
-                                       "/bin/wine-preloader"))
-             ;; Copy the missing man file for the wine binary from wine-staging.
-             (system (string-append "gunzip < " (string-append (assoc-ref
-                                    %build-inputs "wine-staging")
-                                    "/share/man/man1/wine.1.gz") "> "
-                                    (string-append (assoc-ref %outputs "out")
-                                    "/share/man/man1/wine.1")))
-             #t))
+             (let* ((wine32 (assoc-ref %build-inputs "wine"))
+                    (out (assoc-ref %outputs "out")))
+               ;; Copy the missing man file for the wine binary from
+               ;; wine-staging.
+               (copy-file (string-append wine32 "/share/man/man1/wine.1.gz")
+                          (string-append out "/share/man/man1/wine.1.gz"))
+               #t)))
          (add-after 'configure 'patch-dlopen-paths
            ;; Hardcode dlopened sonames to absolute paths.
            (lambda _