summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-02 17:38:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-03 13:27:17 +0100
commite6d30cf7552502b59c2996b5b1d530c38b88c4f7 (patch)
treef6ccdb7b42bd89225c2cff5f1981f7b481fdb184
parent9d13f82da88c5832444534270801da0ee813a397 (diff)
downloadguix-e6d30cf7552502b59c2996b5b1d530c38b88c4f7.tar.gz
gnu: conky: Remove redundant MKDIR-P.
* gnu/packages/conky.scm (conky)[arguments]: Remove redundant MKDIR-P.
-rw-r--r--gnu/packages/conky.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 22a0427b9a..0da9f8438b 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -60,8 +60,8 @@
              #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
-             (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
-               (mkdir-p bin)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin")))
                (install-file "src/conky" bin))
              #t)))))
     (inputs