summary refs log tree commit diff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-02-25 18:58:05 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-03 17:55:34 +0100
commite8f161ea11c24b9812d74e6793f5d7f8e789e170 (patch)
tree5a4cc8020b6f63493fadd63d3cc985be72240a83
parentffc5d42fc2589c349579c00e9dd11fabdff2663b (diff)
downloadguix-e8f161ea11c24b9812d74e6793f5d7f8e789e170.tar.gz
services: desktop: Deprecate 'udisks-service' procedure.
* doc/guix.texi (Desktop Services): Replace 'udisks-service' with 'udisks-service-type'.
Document <udisks-configuration>.
* gnu/packages/kde-multimedia.scm (k3b)[description]: Replace 'udisks-service' with 'udisks-service-type'.
* gnu/services/desktop.scm (udisks-service-type): Set default value.
(udisks-service): Deprecate procedure.
(desktop-services-for-system): Use udisks-service-type.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--doc/guix.texi21
-rw-r--r--gnu/packages/kde-multimedia.scm4
-rw-r--r--gnu/services/desktop.scm10
3 files changed, 25 insertions, 10 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 4ff5622ad3..659f451933 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -23537,9 +23537,10 @@ Possible values are:
 @end table
 @end deftp
 
-@deffn {Scheme Procedure} udisks-service [#:udisks @var{udisks}]
-Return a service for @uref{https://udisks.freedesktop.org/docs/latest/,
-UDisks}, a @dfn{disk management} daemon that provides user interfaces
+@defvar udisks-service-type
+Type for the service that runs
+@uref{https://udisks.freedesktop.org/docs/latest/, UDisks},
+a @dfn{disk management} daemon that provides user interfaces
 with notifications and ways to mount/unmount disks.  Programs that talk
 to UDisks include the @command{udisksctl} command, part of UDisks, and
 GNOME Disks.  Note that Udisks relies on the @command{mount} command, so
@@ -23547,7 +23548,19 @@ it will only be able to use the file-system utilities installed in the
 system profile.  For example if you want to be able to mount NTFS
 file-systems in read and write fashion, you'll need to have
 @code{ntfs-3g} installed system-wide.
-@end deffn
+
+The value for this service is a @code{<udisks-configuration>} object.
+@end defvar
+
+@deftp {Data Type} udisks-configuration
+Data type representing the configuration for @code{udisks-service-type}.
+
+@table @asis
+@item @code{udisks} (default: @code{udisks}) (type: file-like)
+Package object for UDisks.
+
+@end table
+@end deftp
 
 @defvar colord-service-type
 This is the type of the service that runs @command{colord}, a system
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index d635eca26d..e3de6db432 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -460,8 +460,8 @@ and provide an easily usable interface.  Features include burning audio CDs
 from .WAV and .MP3 audio files, configuring external programs and configuring
 devices.
 
-The @code{udisks-service} should be enabled for @command{k3b} to discover the
-available CD drives.")
+The @code{udisks-service-type} should be enabled for @command{k3b} to discover
+the available CD drives.")
     (license ;; GPL for programs, FDL for documentation
      (list license:gpl2+ license:fdl1.2+))))
 
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index 4a790fbdc4..99a3628606 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -97,7 +97,7 @@
 
             udisks-configuration
             udisks-configuration?
-            udisks-service
+            udisks-service  ; deprecated
             udisks-service-type
 
             colord-service-type
@@ -945,9 +945,11 @@ screens and scanners.")))
                   (description "Run UDisks, a @dfn{disk management} daemon
 that provides user interfaces with notifications and ways to mount/unmount
 disks.  Programs that talk to UDisks include the @command{udisksctl} command,
-part of UDisks, and GNOME Disks."))))
+part of UDisks, and GNOME Disks.")
+                  (default-value (udisks-configuration)))))
 
-(define* (udisks-service #:key (udisks udisks))
+(define-deprecated (udisks-service #:key (udisks udisks))
+  udisks-service-type
   "Return a service for @uref{http://udisks.freedesktop.org/docs/latest/,
 UDisks}, a @dfn{disk management} daemon that provides user interfaces with
 notifications and ways to mount/unmount disks.  Programs that talk to UDisks
@@ -1858,7 +1860,7 @@ applications needing access to be root.")
 
          ;; The D-Bus clique.
          (service avahi-service-type)
-         (udisks-service)
+         (service udisks-service-type)
          (service upower-service-type)
          (service accountsservice-service-type)
          (service cups-pk-helper-service-type)