summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-08-10 19:43:11 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-06 01:25:30 -0400
commite90b54ee99d78d801b497053c937c002dc19aed3 (patch)
tree65a50be8d35c7e0401a6eb8f93e7ab04e0bd26a3
parente99279aa2706ff2471d234db4e3ad0c67239c2dd (diff)
downloadguix-e90b54ee99d78d801b497053c937c002dc19aed3.tar.gz
gnu: Add go-github-com-tdewolff-hasher.
* gnu/packages/golang.scm (go-github-com-tdewolff-hasher): New variable.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7e294f9eee..9fc7bd9031 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3644,6 +3644,32 @@ per-goroutine.")
     (description "The @code{walker} function is a faster, parallel version, of
 @code{filepath.Walk}")))
 
+(define-public go-github-com-tdewolff-hasher
+  (package
+    (name "go-github-com-tdewolff-hasher")
+    (version "0.0.0-20210521220142-bc97f602bca2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tdewolff/hasher")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "12dmxpmdy2z7c2z7qv2mv2aq4hyvjncb6fzr0ymg3y5bfjvl4dcw"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/tdewolff/hasher"))
+    (native-inputs
+     (list go-github-com-cespare-mph
+           go-github-com-dgryski-go-mph))
+    (home-page "https://github.com/tdewolff/hasher")
+    (synopsis "Go known-keys fast-lookup map generator")
+    (description
+     "Hasher is a tool to automate the creation of methods and tables for a
+@code{string} to @code{uint32} mapper.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-tdewolff-minify-v2
   (package
     (name "go-github-com-tdewolff-minify-v2")