summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-25 21:27:20 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 10:55:07 +0100
commite90fe9e7a128da852c057fc61c77a6cc02482b41 (patch)
treecdd9e15b1053bc24abcfe2069543b981a3a7e70b
parentbba0676e86601c248cd0f3642a90b061af1f5b4d (diff)
downloadguix-e90fe9e7a128da852c057fc61c77a6cc02482b41.tar.gz
gnu: python-rpy2: Update to 3.5.15.
* gnu/packages/statistics.scm (python-rpy2): Update to 3.5.15.
[inputs]: Add zlib.
[native-inputs]: Add python-coverage, python-ipython, python-numpy,
python-pandas, python-pytest, and python-pytest-cov.
-rw-r--r--gnu/packages/statistics.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index a8c42d7707..aa8c586cc0 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6681,14 +6681,14 @@ completion.")
 (define-public python-rpy2
   (package
     (name "python-rpy2")
-    (version "3.5.5")
+    (version "3.5.15")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "rpy2" version))
         (sha256
          (base32
-          "0dyhb3xn2p6s67yxhgh4qd4hp45mhb5zvgqkdsn26kyg447c8lm2"))))
+          "0asvybb7kmr48pfkibp1qi3h3vlq2fl0mazaf0xj6zywhi5awks4"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -6717,9 +6717,15 @@ completion.")
            r-rsqlite
            r-dplyr
            r-dbplyr
-           python-numpy))
+           python-numpy
+           zlib))
     (native-inputs
-     (list zlib python-pytest))
+     (list python-coverage
+           python-ipython
+           python-numpy
+           python-pandas
+           python-pytest
+           python-pytest-cov))
     (home-page "https://rpy2.github.io")
     (synopsis "Python interface to the R language")
     (description "rpy2 is a redesign and rewrite of rpy.  It is providing a