summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2023-07-26 00:15:09 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:42:41 +0100
commite912866ce9e0ba179554ef4091dc81518b3245fe (patch)
tree8b16db8422699eb937a561bdfd048047cc417965
parenta206fd3d2c4d9f0761e7a663ccb9534eff87cb93 (diff)
downloadguix-e912866ce9e0ba179554ef4091dc81518b3245fe.tar.gz
gnu: Add ruby-sfl.
* gnu/packages/ruby.scm (ruby-sfl): New variable.
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f4284a834b..ece5192f16 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12983,6 +12983,26 @@ manifest file.")
     (home-page "https://github.com/mvz/rake-manifest")
     (license license:expat)))
 
+(define-public ruby-sfl
+  (package
+    (name "ruby-sfl")
+    (version "2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "sfl" version))
+              (sha256
+               (base32
+                "1qm4hvhq9pszi9zs1cl9qgwx1n4wxq0af0hq9sbf6qihqd8rwwwr"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:tests? #f  ;; some tests fail, gem is a dummy for ruby >= 1.9 anyway
+       #:test-target "spec"))
+    (synopsis "Spawn for Ruby 1.8")
+    (description "This pure ruby library provides @code{spawn()} which is
+almost perfectly compatible with ruby 1.9's.")
+    (home-page "https://github.com/ujihisa/spawn-for-legacy")
+    (license license:bsd-2)))
+
 (define-public ruby-childprocess
   (package
     (name "ruby-childprocess")