summary refs log tree commit diff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 15:11:50 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commite916e211023e34c2a01c36dd8378fbe4acadff3d (patch)
treed52095b9cfdbc2df8ca69ec093cfeae1c61ef860
parenta39f3936a9eea02e4beb38680da42cf0fe37828f (diff)
downloadguix-e916e211023e34c2a01c36dd8378fbe4acadff3d.tar.gz
gnu: Add ghc-parallel.
* gnu/packages/haskell.scm (ghc-parallel): New variable.
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0c86d508c6..2e8244aca3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -328,4 +328,26 @@ access to the full zlib feature set.")
      "A modular composable concurrency abstraction.")
     (license bsd-3)))
 
+(define-public ghc-parallel
+  (package
+    (name "ghc-parallel")
+    (version "3.2.0.6")
+    (outputs '("out" "doc"))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://hackage.haskell.org/package/parallel/parallel-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0hp6vf4zxsw6vz6lj505xihmnfhgjp39c9q7nyzlgcmps3xx6a5r"))))
+    (build-system haskell-build-system)
+    (home-page "http://hackage.haskell.org/package/parallel")
+    (synopsis "Parallel programming library")
+    (description
+     "This package provides a library for parallel programming.")
+    (license bsd-3)))
+
 ;;; haskell.scm ends here