summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-10-30 00:01:02 +0100
committerAndreas Enge <andreas@enge.fr>2014-10-30 00:01:02 +0100
commite9a6d2252c5d35f7c22474280547f94461121265 (patch)
treebe4b6b383010c4259081caf2acb357a28e9eaafd
parentb32c8549e42be25827ebb686a72d6f59c56a7511 (diff)
downloadguix-e9a6d2252c5d35f7c22474280547f94461121265.tar.gz
gnu: texlive: Move script packages from native-inputs to inputs.
* gnu/packages/texlive.scm (texlive): Move perl, python and tcsh from
    native inputs to inputs.
-rw-r--r--gnu/packages/texlive.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/texlive.scm b/gnu/packages/texlive.scm
index 5d6cc651fd..02637befe4 100644
--- a/gnu/packages/texlive.scm
+++ b/gnu/packages/texlive.scm
@@ -80,18 +80,18 @@
              ("libpng" ,libpng)
              ("libxaw" ,libxaw)
              ("libxt" ,libxt)
+             ("perl" ,perl)
              ("pixman" ,pixman)
              ("poppler" ,poppler)
              ("potrace" ,potrace)
+             ("python" ,python-2) ; incompatible with Python 3 (print syntax)
              ("ruby" ,ruby)
+             ("tcsh" ,tcsh)
              ("teckit" ,teckit)
              ("zlib" ,zlib)
              ("zziplib" ,zziplib)))
    (native-inputs
-    `(("perl" ,perl)
-      ("pkg-config" ,pkg-config)
-      ("python" ,python-2) ; incompatible with Python 3 (print syntax)
-      ("tcsh" ,tcsh)))
+    `(("pkg-config" ,pkg-config)))
    (outputs '("out" "data"))
    (arguments
     `(#:out-of-source? #t