summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-12 10:16:52 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:38 +0800
commitea41f757b9b139a8e3bb746392e90f9119c6c83b (patch)
treed8750d023c4704274cfe7f632ed40a8807229749
parent07b9ca3449903e202528347f6a41a24362f421bc (diff)
downloadguix-ea41f757b9b139a8e3bb746392e90f9119c6c83b.tar.gz
gnu: attica: Use G-expressions.
* gnu/packages/kde-frameworks.scm (attica)[arguments]:
Rewrite as G-expressions.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/kde-frameworks.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index d654fcc621..206ce38d17 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -305,13 +305,14 @@ Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
                 "15didd7llqamp9wbvrynnf9cap2dqmwr51mz0pcjdk0iqs6ym4qq"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'disable-network-tests
-           (lambda _
-             ;; These tests require network access.
-             (substitute* "autotests/CMakeLists.txt"
-               ((".*providertest.cpp") "")))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'disable-network-tests
+            (lambda _
+              ;; These tests require network access.
+              (substitute* "autotests/CMakeLists.txt"
+                ((".*providertest.cpp") "")))))))
     (native-inputs
      (list extra-cmake-modules))
     (inputs