summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-12 23:28:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-14 14:15:33 +0100
commiteacd68aa444e72beca91ee71da658ba3b5f20d24 (patch)
tree2b2d428396fbbde4eb4d3ac79326cec266692a11
parent42bb34e21a768adbe1c0bacce070e0cb728c8231 (diff)
downloadguix-eacd68aa444e72beca91ee71da658ba3b5f20d24.tar.gz
gnu: Add librnd.
* gnu/packages/engineering.scm (librnd): New variable.
-rw-r--r--gnu/packages/engineering.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ebcc0f453c..c463e1c86f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -420,6 +420,45 @@ materials (BOM) generation, netlisting into over 20 netlist formats, analog
 and digital simulation, and printed circuit board (PCB) layout, and many other
 features.")))
 
+(define-public librnd
+  (package
+    (name "librnd")
+    (version "4.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.repo.hu/projects/librnd/releases/"
+                                  "librnd-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1fqh7gf9imhghlfajrsgzjx61mynfmdasciwpcajk7pn85d4ymql"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #false                   ;no check target
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'cc-is-gcc
+            (lambda _ (setenv "CC" "gcc")))
+          (replace 'configure
+            ;; The configure script doesn't tolerate most of our configure flags.
+            (lambda _
+              (invoke "sh" "configure"
+                      (string-append "--prefix=" #$output)))))))
+    (inputs
+     (list gd gtk glib glu))
+    (native-inputs
+     (list pkg-config))
+    (home-page "http://repo.hu/projects/librnd/")
+    (synopsis "Two-dimensional CAD engine")
+    (description "This is a flexible, modular two-dimensional CAD engine
+@itemize
+@item with transparent multiple GUI toolkit support;
+@item a flexible, dynamic menu system;
+@item a flexible, dynamic configuration system; and
+@item support for user scripting in a dozen languages.
+@end itemize")
+    (license license:gpl2+)))
+
 (define-public pcb
   (package
     (name "pcb")