summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-02 23:09:47 +0100
committerMarius Bakke <marius@gnu.org>2021-12-05 14:02:09 +0100
commiteb8619a5a6e1193e06a8bf9aecae2e5607a465bc (patch)
treea7188f599695047f544410d8759356f7778616f0
parentd801827b846d9cde9e93797c20600651697b111a (diff)
downloadguix-eb8619a5a6e1193e06a8bf9aecae2e5607a465bc.tar.gz
gnu: python-alembic: Update to 1.7.5.
* gnu/packages/databases.scm (python-alembic): Update to 1.7.5.
[propagated-inputs]: Remove PYTHON-IMPORTLIB-RESOURCES.
-rw-r--r--gnu/packages/databases.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 00baaab532..a817e1f9e2 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3237,13 +3237,13 @@ this library provides functions to facilitate such comparisons.")
 (define-public python-alembic
   (package
     (name "python-alembic")
-    (version "1.7.1")
+    (version "1.7.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "alembic" version))
        (sha256
-        (base32 "1ys0a44gh544xpbzz6r5xvz3msim74f9qklyfnw0bhn9vk9n9adf"))))
+        (base32 "0lxi2g2025lz5k7k5dd5fc1lfijqi2yw6qqyjzp073z6laa8cckw"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
@@ -3255,7 +3255,6 @@ this library provides functions to facilitate such comparisons.")
        ("python-pytest-cov" ,python-pytest-cov)))
     (propagated-inputs
      `(("python-dateutil" ,python-dateutil)
-       ("python-importlib-resources" ,python-importlib-resources) ;Python < 3.9
        ("python-sqlalchemy" ,python-sqlalchemy)
        ("python-mako" ,python-mako)
        ("python-editor" ,python-editor)))