summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:09 +0200
commitec0e817048ee4557b461690ce31fc6944fd57304 (patch)
tree8b53e4269987e634567a1f2cc4444719349526ca
parente4cf69da2954e3334ce70f8defe0ce4483273fa6 (diff)
downloadguix-ec0e817048ee4557b461690ce31fc6944fd57304.tar.gz
gnu: Add texlive-sillypage.
* gnu/packages/tex.scm (texlive-sillypage): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a9bfb253fb..b0cb281dfb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -95651,6 +95651,27 @@ messages that begin with...'').  Messages may be saved to an external file for
 later reference.")
     (license license:lppl)))
 
+(define-public texlive-sillypage
+  (package
+    (name "texlive-sillypage")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/sillypage/"
+                   "source/latex/sillypage/"
+                   "tex/latex/sillypage/")
+             (base32
+              "04jnp1hl3k0hs8rgzn1q3q41rmd95wlzv7f1dd9s4affzfk6an1z")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/sillypage")
+    (synopsis "John Cleese's silly walk as page numbering style")
+    (description
+     "This simple LaTeX package provides John Cleese's iconic silly walk routine as
+a page numbering style.  Other counters, as well as integers, can be typeset
+in this silly style, too.")
+    (license (list license:cc-by-sa4.0 license:lppl1.3c))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar