summary refs log tree commit diff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-11-03 20:37:19 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-11-04 11:14:22 +0200
commitecf33bf17c3bf9626612bd5958e2f5a6698c4cfc (patch)
tree279560ea6ffa83d0f12791715c28d35a061e707d
parent5d3bcfefb6ea4a4f13aa17276c6e74b9f19532d2 (diff)
downloadguix-ecf33bf17c3bf9626612bd5958e2f5a6698c4cfc.tar.gz
gnu: synapse: Update to 1.22.1.
* gnu/packages/matrix.scm (synapse): Update to 1.22.1.
[propagated-inputs]: Add python-packaging.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/matrix.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 83a0d478af..6a6cc628ca 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -61,13 +61,13 @@ an LDAP server.")
 (define-public synapse
   (package
     (name "synapse")
-    (version "1.20.1")
+    (version "1.22.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "matrix-synapse" version))
               (sha256
                (base32
-                "1sf36vwvy2f9jy6dldq6gqfmh60384i5j64s7yc131b4dp0n7lcw"))))
+                "1pbxdqpfa7wzdz61p6x58x7841vng1g65qayxgcw73bn1shl50jb"))))
     (build-system python-build-system)
     ;; TODO Run tests with ‘PYTHONPATH=. trial3 tests’.
     (propagated-inputs
@@ -109,6 +109,7 @@ an LDAP server.")
        ("python-txacme" ,python-txacme)
        ("python-pysaml2" ,python-pysaml2)
        ("python-lxml" ,python-lxml)
+       ("python-packaging" ,python-packaging)
        ;; sentry-sdk, jaeger-client, and opentracing could be included, but
        ;; all are monitoring aids and not essential.
        ("python-pyjwt" ,python-pyjwt)))