summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-07-25 20:03:10 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-07-25 20:08:27 +0530
commited9d14673471b0f2f8425ae359c8d3c27aec545d (patch)
tree474ca6ea8e80f8ccc3a2881be34f3a46eaea4a5d
parentd1318cb4dee1300ed5719a556ed9a624a0a464fe (diff)
downloadguix-ed9d14673471b0f2f8425ae359c8d3c27aec545d.tar.gz
gnu: oil: Respect #:tests?.
* gnu/packages/shells.scm (oil)[arguments]: Respect #:tests? in the custom
check phase.
-rw-r--r--gnu/packages/shells.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 1bfc2ba213..d51c67f3fa 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -8,7 +8,7 @@
 ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017, 2018 Nikita <nikita@n0.is>
 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2021 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019 Meiyo Peng <meiyo.peng@gmail.com>
 ;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -855,11 +855,11 @@ Shell (pdksh).")
            ;; The tests are not distributed in the tarballs but upstream
            ;; recommends running this smoke test.
            ;; https://github.com/oilshell/oil/blob/release/0.8.0/INSTALL.txt#L38-L48
-           (lambda _
-             (let* ((oil "_bin/oil.ovm"))
-               (invoke/quiet oil "osh" "-c" "echo hi")
-               (invoke/quiet oil "osh" "-n" "configure")
-               #t))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (let* ((oil "_bin/oil.ovm"))
+                 (invoke/quiet oil "osh" "-c" "echo hi")
+                 (invoke/quiet oil "osh" "-n" "configure"))))))))
     (inputs
      `(("readline" ,readline)))
     (home-page "https://www.oilshell.org")