summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-02 22:43:26 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-02 22:43:26 +0100
commitee46bc5983063d5662417d722e85e00abb6737de (patch)
treec31feafaa4b379f897a46966926f7030f655feb6
parent07f7bf3624b519498b694825eb6b9b0f45af7492 (diff)
downloadguix-ee46bc5983063d5662417d722e85e00abb6737de.tar.gz
gnu: Add go-github-com-google-go-cmp-cmp.
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): New variable.
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5d2eef699b..d66527c660 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3058,3 +3058,27 @@ sensors).")
 colorized or SGR defined output to the standard output.")
     (home-page "https://godoc.org/github.com/fatih/color")
     (license license:expat)))
+
+(define-public go-github-com-google-go-cmp-cmp
+  (package
+    (name "go-github-com-google-go-cmp-cmp")
+    (version "0.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/google/go-cmp.git")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1caw49i0plkjxir7kdf5qhwls3krqwfmi7g4h392rdfwi3kfahx1"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/google/go-cmp/cmp"
+       #:unpack-path "github.com/google/go-cmp"))
+    (synopsis "Determine equality of values in Go")
+    (description "This package provides a more powerful and safer
+alternative to @code{reflect.DeepEqual} for comparing whether two values
+are semantically equal in Go (for writing tests).")
+    (home-page "https://godoc.org/github.com/google/go-cmp/cmp")
+    (license license:asl2.0)))