summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-08-22 14:14:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-23 12:02:50 +0200
commitee676283e2dbd38bf40ef21ccd4e7493baa2ad6d (patch)
treea194bd99a110152f0c48e1a1438c795b1c563872
parent4a6c6484df286203a2cb6ed5c431047febf499f2 (diff)
downloadguix-ee676283e2dbd38bf40ef21ccd4e7493baa2ad6d.tar.gz
gnu: Add r-rvenn.
* gnu/packages/cran.scm (r-rvenn): New variable.
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3d1fcc928d..20fa3a930d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -749,6 +749,42 @@ similar rank-based tests for equal probability distributions due to Neuhauser
 WebAssembly engine.")
     (license license:expat)))
 
+(define-public r-rvenn
+  (package
+    (name "r-rvenn")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RVenn" version))
+       (sha256
+        (base32
+         "016m00xv59lkwm2is32v5nr4lw5a1ymdnz34r3ffflcv9bfrc6n4"))))
+    (properties `((upstream-name . "RVenn")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-ggforce
+           r-ggplot2
+           r-magrittr
+           r-pheatmap
+           r-purrr
+           r-rlang
+           r-vegan))
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=RVenn")
+    (synopsis "Set operations for many sets")
+    (description
+     "The base functions for set operations in @code{R} can be used for only two
+sets.  This package @code{RVenn} provides functions for dealing with multiple sets.
+It uses @code{purr} to find the union, intersection and difference of three or
+more sets.  This package also provides functions for pairwise set operations among
+several sets.  Further, based on @code{ggplot2} and @code{ggforce}, a Venn diagram
+can be drawn for two or three sets.  For bigger data sets, a clustered heatmap
+showing the presence or absence of the elements of the sets can be drawn based on
+the @code{pheatmap} package.  Finally, enrichment test can be applied to two sets
+whether an overlap is statistically significant or not.")
+    (license license:gpl3)))
+
 (define-public r-dot
   (package
     (name "r-dot")