summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-06 21:57:42 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-06 21:57:42 +0200
commitef1c4148384c66cb99facd8a20ca1dc73644926a (patch)
treefe2af3056ea289fd8be99f1dd98d5bcff7d8c7e3
parent97aee2b6a57a66608ee9eee919933f2e4900886e (diff)
downloadguix-ef1c4148384c66cb99facd8a20ca1dc73644926a.tar.gz
gnu: Add libfreehand.
* gnu/packages/libreoffice.scm (libfreehand): New variable.
-rw-r--r--gnu/packages/libreoffice.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 4df809528c..2f7b4d7e99 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -306,3 +306,29 @@ Apple Keynote documents.  It currently supports Keynote versions 2 to 5.")
 library primarily intended for language guessing.")
     (license (non-copyleft "file://LICENSE"
                            "See LICENSE in the distribution."))))
+
+(define-public libfreehand
+  (package
+    (name "libfreehand")
+    (version "0.1.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+                          name "-" version ".tar.xz"))
+      (sha256 (base32
+               "01j7mxi4lmf72w1mv2r098p8l0csdd94w2gq0ncp93djn34al6ai"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("doxygen" ,doxygen)
+       ("gperf" ,gperf)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("librevenge" ,librevenge)
+       ("zlib" ,zlib)))
+    (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libfreehand")
+    (synopsis "Library for parsing the FreeHand format")
+    (description "Libfreehand is a library that parses the file format of
+Aldus/Macromedia/Adobe FreeHand documents.")
+    (license mpl2.0)))