summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 01:23:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 12:02:52 +0100
commitef4c5a413e099e58ccfddff1586d941b7c3ab2df (patch)
tree386226189bfab34eb1d92186db5b66a3424e3a42
parentaf2f11ff00af569f76550b290037818e98e28b29 (diff)
downloadguix-ef4c5a413e099e58ccfddff1586d941b7c3ab2df.tar.gz
gnu: gimp: Do not run gtk-update-icon-cache during the build process.
* gnu/packages/gimp.scm (gimp)[arguments]: Add
"ac_cv_path_GTK_UPDATE_ICON_CACHE" in #:configure-flags.
-rw-r--r--gnu/packages/gimp.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 8aa69da7c3..9ff380e167 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -151,6 +152,10 @@ buffers.")
        (list (string-append "--with-html-dir="
                             (assoc-ref %outputs "doc")
                             "/share/gtk-doc/html")
+             ;; Prevent the build system from running 'gtk-update-icon-cache'
+             ;; which is not needed during the build because Guix runs it at
+             ;; profile creation time.
+             "ac_cv_path_GTK_UPDATE_ICON_CACHE=true"
              ;; ./configure requests not to annoy upstream with packaging bugs.
              "--with-bug-report-url=https://bugs.gnu.org/guix")
        #:phases