summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:16:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:13 +0200
commitef660a6e7af270b574b7da3c9ff69168d64f61b3 (patch)
treecdc1231fdc15261181f60a7abec6baeb239839c8
parente20643e3bec381eb154c79bfac166bfb37c4479f (diff)
downloadguix-ef660a6e7af270b574b7da3c9ff69168d64f61b3.tar.gz
gnu: Add texlive-latex-web-companion.
* gnu/packages/tex.scm (texlive-latex-web-companion): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4467bf9af1..d9bbd7298a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18417,6 +18417,24 @@ version of the document is provided in the distribution, as PDF.  An analogous
 version is provided in legal format.")
     (license license:lppl1.3+)))
 
+(define-public texlive-latex-web-companion
+  (package
+    (name "texlive-latex-web-companion")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/latex-web-companion/")
+             (base32
+              "0v018lwf88z3qmzyqpyvfql7dbwk5a9r0wj3jfjc9cp2ksl8zf8f")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lwc-examples")
+    (synopsis "Examples from @emph{The LaTeX Web Companion}")
+    (description
+     "This package contains the source of the examples printed in @emph{The
+LaTeX Web Companion} book, together with necessary supporting files.")
+    (license license:lppl)))
+
 (define-public texlive-oberdiek
   (package
     (name "texlive-oberdiek")