summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:32:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:52 +0200
commitef724f3067ca880bbc4c48e062a00701667680c4 (patch)
tree468e424d6f0eb7e3e90a97d58433e2c286416755
parente31843cdbf8295aeb3a0d1376231781b3e2abb09 (diff)
downloadguix-ef724f3067ca880bbc4c48e062a00701667680c4.tar.gz
gnu: Add texlive-tie.
* gnu/packages/tex.scm (texlive-tie): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a48d463b40..ebe69efc48 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6671,6 +6671,29 @@ the help of TikZ.  It also provides commands to draw the content of screens
 and of menu items.")
     (license license:lppl)))
 
+(define-public texlive-tie
+  (package
+    (name "texlive-tie")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/tie.1"
+                   "doc/man/man1/tie.man1.pdf")
+             (base32
+              "17z5ik7bbf0v5ylq2v1rda6z64iz386vp56z7yrr6h1dl488kr93")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-kpathsea))
+    (home-page "https://ctan.org/pkg/tie")
+    (synopsis "Allow multiple web change files")
+    (description
+     "Tie was originally developed to allow web programmers to apply more than
+one change file to their source.  The program may also be used to create a new
+version of a @file{.web} file that incorporates existing changes.")
+    ;; The license, provided as the "tie.w" source file, is morally equivalent
+    ;; to CC BY-SA.
+    (license (license:fsf-free "file://tie.w"))))
+
 (define-public texlive-tikz-3dplot
   (package
     (name "texlive-tikz-3dplot")