summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-21 20:34:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-21 20:34:49 +0200
commitefa0ba499e78af732f302cbcd4002df6e259921e (patch)
tree90f57e970497e9a8e089b45d8305ce3ce0a7ceb6
parent595dcd48a965462ad45f19e42864ae972f34183d (diff)
parente2a95f8b16674ae2965bf155b6d28ca5942abb03 (diff)
downloadguix-efa0ba499e78af732f302cbcd4002df6e259921e.tar.gz
Merge branch 'master' into staging
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/astronomy.scm10
-rw-r--r--gnu/packages/emacs.scm7
-rw-r--r--gnu/packages/gnome.scm34
-rw-r--r--gnu/packages/machine-learning.scm11
-rw-r--r--gnu/packages/patches/emacs-unsafe-enriched-mode-translations.patch85
-rw-r--r--gnu/packages/simulation.scm4
-rw-r--r--gnu/packages/version-control.scm38
-rw-r--r--gnu/packages/vim.scm4
-rw-r--r--gnu/packages/virtualization.scm4
10 files changed, 93 insertions, 105 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8dfc1b71f2..5731d1ee84 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -593,7 +593,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/emacs-fix-scheme-indent-function.patch	\
   %D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch	\
   %D%/packages/patches/emacs-source-date-epoch.patch		\
-  %D%/packages/patches/emacs-unsafe-enriched-mode-translations.patch	\
   %D%/packages/patches/erlang-man-path.patch			\
   %D%/packages/patches/eudev-rules-directory.patch		\
   %D%/packages/patches/evilwm-lost-focus-bug.patch		\
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 132013b57a..a1f5bd1820 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -64,7 +64,7 @@ in FITS files.")
 (define-public wcslib
   (package
     (name "wcslib")
-    (version "5.16")
+    (version "5.17")
     (source
      (origin
        (method url-fetch)
@@ -72,7 +72,7 @@ in FITS files.")
              "ftp://ftp.atnf.csiro.au/pub/software/wcslib/" name "-" version
              ".tar.bz2"))
        (sha256
-        (base32 "1vwrzkznpig2q40m11j12hsfqvsjz8z44l66pz5fkh6fy461w0zd"))))
+        (base32 "0v23x1fw01arhmqdrzfd9n593mjglhzfyx4793v065z0dg4bb72w"))))
     (inputs
      `(("cfitsio" ,cfitsio)))
     (build-system gnu-build-system)
@@ -83,7 +83,7 @@ in FITS files.")
                       (substitute* "makedefs.in"
                         (("/bin/sh") "sh"))
                       #t)))))
-    (home-page "http://www.atnf.csiro.au/people/mcalabre/WCS")
+    (home-page "https://www.atnf.csiro.au/people/mcalabre/WCS")
     (synopsis "Library which implements the FITS WCS standard")
     (description "The FITS \"World Coordinate System\" (WCS) standard defines
 keywords and usage that provide for the description of astronomical coordinate
@@ -93,7 +93,7 @@ systems in a FITS image header.")
 (define-public gnuastro
   (package
     (name "gnuastro")
-    (version "0.3")
+    (version "0.4")
     (source
      (origin
        (method url-fetch)
@@ -101,7 +101,7 @@ systems in a FITS image header.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "109xjwbs36gbkx5sd5yzf6ailfcldc5d28vl1n19z0ylfzww4nwa"))))
+         "1n30zz4kg89ic5h30b7nrxp0bk0ls2m3xnfi81mja56bxxwpihrs"))))
     (inputs
      `(("cfitsio" ,cfitsio)
        ("gsl" ,gsl)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6faa01548b..e203cfcd82 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -103,18 +103,17 @@
 (define-public emacs
   (package
     (name "emacs")
-    (version "25.2")
+    (version "25.3")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/emacs/emacs-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1ykkq0xl28ljdg61bm6gzy04ww86ajms98gix72qg6cpr6a53dar"))
+               "02y00y9q42g1iqgz5qhmsja75hwxd88yrn9zp14lanay0zkwafi5"))
              (patches (search-patches "emacs-exec-path.patch"
                                       "emacs-fix-scheme-indent-function.patch"
-                                      "emacs-source-date-epoch.patch"
-                                      "emacs-unsafe-enriched-mode-translations.patch"))
+                                      "emacs-source-date-epoch.patch"))
              (modules '((guix build utils)))
              (snippet
               ;; Delete the bundled byte-compiled elisp files and
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b3624d6dca..f8451fd830 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -138,6 +138,7 @@
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages speech)
   #:use-module (gnu packages virtualization)
+  #:use-module (gnu packages vpn)
   #:use-module (srfi srfi-1))
 
 (define-public brasero
@@ -5039,6 +5040,39 @@ services.")
     (license license:gpl2+)
     (properties '((upstream-name . "NetworkManager")))))
 
+(define-public network-manager-openvpn
+  (package
+    (name "network-manager-openvpn")
+    (version "1.2.10")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://gnome/sources/NetworkManager-openvpn/"
+                    (version-major+minor version)
+                    "/NetworkManager-openvpn-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0q9x61fq509gybz3ljzyvf9zn8nlya1r2vk7jl0gk3fp76jsg1mc"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--enable-absolute-paths")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("intltool" ,intltool)))
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("openvpn" ,openvpn)
+       ("network-manager" ,network-manager)
+       ("network-manager-applet" ,network-manager-applet) ;for libnma
+       ("libsecret" ,libsecret)))
+    (home-page "https://wiki.gnome.org/Projects/NetworkManager/VPN")
+    (synopsis "OpenVPN plug-in for NetworkManager")
+    (description
+     "This extension of NetworkManager allows it to take care of connections
+to virtual private networks (VPNs) via OpenVPN.")
+    (license license:gpl2+)
+    (properties `((upstream-name . "NetworkManager-openvpn")))))
+
 (define-public mobile-broadband-provider-info
   (package
     (name "mobile-broadband-provider-info")
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 291146bab4..4af36d9823 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -520,14 +520,14 @@ and a QP solver.")
 (define-public dlib
   (package
     (name "dlib")
-    (version "19.3")
+    (version "19.7")
     (source (origin
               (method url-fetch)
               (uri (string-append
                     "http://dlib.net/files/dlib-" version ".tar.bz2"))
               (sha256
                (base32
-                "0gfy83av717qymv53yv7ki6mgh6mdw4xcxxbjk8lrs72f8qvnrcw"))
+                "1mljz02kwkrbggyncxv5fpnyjdybw2qihaacb3js8yfkw12vwpc2"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -537,7 +537,11 @@ and a QP solver.")
                   #t))))
     (build-system cmake-build-system)
     (arguments
-     `(#:phases
+     ;; Recent releases defaults to "lib64" on 64bit.
+     `(#:configure-flags (list (string-append "-DCMAKE_INSTALL_LIBDIR="
+                                              (assoc-ref %outputs "out")
+                                              "/lib"))
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-asserts
            (lambda _
@@ -572,7 +576,6 @@ and a QP solver.")
              ;; No test target, so we build and run the unit tests here.
              (let ((test-dir (string-append "../dlib-" ,version "/dlib/test")))
                (with-directory-excursion test-dir
-                 (setenv "CXXFLAGS" "-std=gnu++11")
                  (and (zero? (system* "make" "-j" (number->string (parallel-job-count))))
                       (zero? (system* "./dtest" "--runall")))))))
          (add-after 'install 'delete-static-library
diff --git a/gnu/packages/patches/emacs-unsafe-enriched-mode-translations.patch b/gnu/packages/patches/emacs-unsafe-enriched-mode-translations.patch
deleted file mode 100644
index 7e45d30129..0000000000
--- a/gnu/packages/patches/emacs-unsafe-enriched-mode-translations.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-This patch fixes a remote code execution vulnerability reported here:
-
-  https://bugs.gnu.org/28350
-  http://www.openwall.com/lists/oss-security/2017/09/11/1
-
-From 9ad0fcc54442a9a01d41be19880250783426db70 Mon Sep 17 00:00:00 2001
-From: Lars Ingebrigtsen <larsi@gnus.org>
-Date: Fri, 8 Sep 2017 20:23:31 -0700
-Subject: Remove unsafe enriched mode translations
-
-* lisp/gnus/mm-view.el (mm-inline-text):
-Do not worry about enriched or richtext type.
-* lisp/textmodes/enriched.el (enriched-translations):
-Remove translations for FUNCTION, display (Bug#28350).
-(enriched-handle-display-prop, enriched-decode-display-prop): Remove.
----
- lisp/gnus/mm-view.el       |  4 ----
- lisp/textmodes/enriched.el | 32 --------------------------------
- 2 files changed, 36 deletions(-)
-
-diff --git a/lisp/gnus/mm-view.el b/lisp/gnus/mm-view.el
-index e5859d0..77ad271 100644
---- a/lisp/gnus/mm-view.el
-+++ b/lisp/gnus/mm-view.el
-@@ -383,10 +383,6 @@
- 	(goto-char (point-max))))
-     (save-restriction
-       (narrow-to-region b (point))
--      (when (member type '("enriched" "richtext"))
--        (set-text-properties (point-min) (point-max) nil)
--	(ignore-errors
--	  (enriched-decode (point-min) (point-max))))
-       (mm-handle-set-undisplayer
-        handle
-        `(lambda ()
-diff --git a/lisp/textmodes/enriched.el b/lisp/textmodes/enriched.el
-index beb6c6d..a8f0d38 100644
---- a/lisp/textmodes/enriched.el
-+++ b/lisp/textmodes/enriched.el
-@@ -117,12 +117,7 @@ expression, which is evaluated to get the string to insert.")
- 		   (full        "flushboth")
- 		   (center      "center"))
-     (PARAMETER     (t           "param")) ; Argument of preceding annotation
--    ;; The following are not part of the standard:
--    (FUNCTION      (enriched-decode-foreground "x-color")
--		   (enriched-decode-background "x-bg-color")
--		   (enriched-decode-display-prop "x-display"))
-     (read-only     (t           "x-read-only"))
--    (display	   (nil		enriched-handle-display-prop))
-     (unknown       (nil         format-annotate-value))
- ;   (font-size     (2           "bigger")       ; unimplemented
- ;		   (-2          "smaller"))
-@@ -477,32 +472,5 @@ Return value is \(begin end name positive-p), or nil if none was found."
-     (message "Warning: no color specified for <x-bg-color>")
-     nil))
- 
--;;; Handling the `display' property.
--
--
--(defun enriched-handle-display-prop (old new)
--  "Return a list of annotations for a change in the `display' property.
--OLD is the old value of the property, NEW is the new value.  Value
--is a list `(CLOSE OPEN)', where CLOSE is a list of annotations to
--close and OPEN a list of annotations to open.  Each of these lists
--has the form `(ANNOTATION PARAM ...)'."
--  (let ((annotation "x-display")
--	(param (prin1-to-string (or old new))))
--    (if (null old)
--        (cons nil (list (list annotation param)))
--      (cons (list (list annotation param)) nil))))
--
--(defun enriched-decode-display-prop (start end &optional param)
--  "Decode a `display' property for text between START and END.
--PARAM is a `<param>' found for the property.
--Value is a list `(START END SYMBOL VALUE)' with START and END denoting
--the range of text to assign text property SYMBOL with value VALUE."
--  (let ((prop (when (stringp param)
--		(condition-case ()
--		    (car (read-from-string param))
--		  (error nil)))))
--    (unless prop
--      (message "Warning: invalid <x-display> parameter %s" param))
--    (list start end 'display prop)))
- 
- ;;; enriched.el ends here
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index cda6f3c567..de07b68440 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -195,8 +195,8 @@
     ;;  $ source $GUIX_PROFILE/lib/OpenFOAM-4.1/etc/bashrc
     ;;  $ mkdir -p $FOAM_RUN
     ;;  $ cd $FOAM_RUN
-    ;;  $ cp -r $FOAM_TUTORIALS/incompressible/simpleFoam/pitzdaily .
-    ;;  $ cd pitzdaily
+    ;;  $ cp -r $FOAM_TUTORIALS/incompressible/simpleFoam/pitzDaily .
+    ;;  $ cd pitzDaily
     ;;  $ chmod -R u+w .
     ;;  $ blockMesh
     (synopsis "Framework for numerical simulation of fluid flow")
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 235adef024..78e142b298 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -713,6 +713,44 @@ Git repository as normal Git commits, and provides a number of commands to
 manipulate them in various ways.")
     (license license:gpl2)))
 
+(define-public vcsh
+  (package
+    (name "vcsh")
+    (version "1.20151229")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/RichiH/vcsh/archive/v"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1ym3swkh738c3vciffvlr96vqzhwmzkb8ajqzap8f0j9n039a1mf"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("which" ,which)))
+    (inputs
+     `(("git" ,git)
+       ("perl" ,perl)
+       ("perl-test-harness" ,perl-test-harness)
+       ("perl-shell-command" ,perl-shell-command)
+       ("perl-test-most" ,perl-test-most)))
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (delete 'build))
+       #:make-flags (list (string-append "PREFIX="
+                                         (assoc-ref %outputs "out")))
+       #:test-target "test"))
+    (home-page "https://github.com/RichiH/vcsh")
+    (synopsis "Version control system for @code{$HOME}")
+    (description
+     "vcsh version-controls configuration files in several Git repositories,
+all in one single directory.  They all maintain their working trees without
+clobbering each other or interfering otherwise.  By default, all Git
+repositories maintained via vcsh store the actual files in @code{$HOME},
+though this can be overridden.")
+    (license license:gpl2+)))
+
 (define-public git-test-sequence
   (let ((commit "48e5a2f5a13a5f30452647237e23362b459b9c76"))
     (package
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 818d2d207f..f4416a5c5c 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -60,7 +60,7 @@
 (define-public vim
   (package
     (name "vim")
-    (version "8.0.0808")
+    (version "8.0.1130")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://github.com/vim/vim/archive/v"
@@ -68,7 +68,7 @@
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
-               "0qrn9fhq5wdrrf2qhpygwfm5rynl32l406xhbr7lg69r9wl8cjjn"))))
+               "0zqyk7086crc6q5fil38szppx9sgd14fs3wb9h4ak13jg6s2ir90"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 8fd3230895..344ffc786b 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -484,7 +484,7 @@ virtualization library.")
 (define-public virt-manager
   (package
     (name "virt-manager")
-    (version "1.4.2")
+    (version "1.4.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://virt-manager.org/download/sources"
@@ -492,7 +492,7 @@ virtualization library.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0x6mnqw8bng3r69pvmnq9q6yyhicxg22yz62b6dzbb4z16xl1r23"))))
+                "093azs8p4p7y4nf5j25xpsvdxww7gky1g0hs8mkcvmpxl2wjd0jj"))))
     (build-system python-build-system)
     (arguments
      `(#:python ,python-2