summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-02-15 22:51:08 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-02-15 22:51:08 +0100
commitf01d53d5afd78e9cef505aaf69221cfed3b05702 (patch)
treed693ec04d1ce784860afab744baebc801df6ad7b
parent3e2334d9457c4bd9ccd9c720de2cf298f0c8f122 (diff)
downloadguix-f01d53d5afd78e9cef505aaf69221cfed3b05702.tar.gz
gnu: Add libacars.
* gnu/packages/radio.scm (libacars): New variable.

Change-Id: I0f849b62de2c3314f215b17d54e7414110dbe828
-rw-r--r--gnu/packages/radio.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index f34511b352..69452f340c 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2017, 2018, 2019, 2020, 2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019, 2020 Christopher Howard <christopher@librehacker.com>
 ;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
-;;; Copyright © 2020, 2021, 2022, 2023 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020-2024 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2020 Charlie Ritter <chewzerita@posteo.net>
 ;;; Copyright © 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -105,6 +105,7 @@
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages web)
   #:use-module (gnu packages wxwidgets)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xml)
@@ -1890,6 +1891,29 @@ their position, altitude, speed, etc.")
     (home-page "https://github.com/flightaware/dump1090")
     (license license:gpl2+)))
 
+(define-public libacars
+  (package
+    (name "libacars")
+    (version "2.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/szpajder/libacars")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "08cadcqzhl3i7hpd8jwph33kx52vdwbrj1rlagwrkwb2mfw6szfs"))))
+    (build-system cmake-build-system)
+    (inputs (list jansson libxml2 zlib))
+    (arguments (list #:tests? #f)) ; No test suite
+    (synopsis "Decoder for ACARS messages")
+    (description "This package provides a library for decoding the contents of
+ACARS messages used by planes.")
+    (home-page "https://github.com/szpajder/libacars")
+    (license (list license:bsd-2
+                   license:expat))))
+
 (define-public rtl-433
   (package
     (name "rtl-433")