summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-25 11:24:17 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 10:55:06 +0100
commitf05a4a00fe8ed68ade0d5c545a51fe41ca931bbb (patch)
treeb318740da643b834d279a191c229d4b1c0833ef1
parent689ca1e73992200fe2edb99baa512590e91ee0c2 (diff)
downloadguix-f05a4a00fe8ed68ade0d5c545a51fe41ca931bbb.tar.gz
gnu: Add lua-clingo.
* gnu/packages/potassco.scm (make-lua-clingo, lua5.1-clingo)
(lua5.2-clingo): New variables.
-rw-r--r--gnu/packages/potassco.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 81d7cfa7e2..39edb3096b 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -36,6 +36,7 @@
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages libffi)
+  #:use-module (gnu packages lua)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
@@ -324,6 +325,29 @@ answer set programming.  It supports a subset of PDDL 3.1 and SAS 3.")
 in particular ones that can be solved by @command{clingo}.")
      (license license:gpl3+))))
 
+(define-public (make-lua-clingo name lua)
+  (package
+    (inherit clingo)
+    (name name)
+    (version (package-version clingo)) ; for #$version in arguments
+    (arguments
+     (substitute-keyword-arguments (package-arguments clingo)
+       ((#:configure-flags flags #~'())
+        #~(cons* "-DCLINGO_BUILD_WITH_LUA=yes"
+                 (string-append "-DLUACLINGO_INSTALL_DIR="
+                                #$output "/lib/lua/"
+                                #$(package-version lua))
+                 "-DCLINGO_USE_LIB=yes"
+                 #$flags))))
+    (inputs (list clingo lua))
+    (synopsis "Lua bindings for clingo")
+    (description "This package provides Lua bindings to the clingo package,
+making it so that you can write @acronym{ASPs, Answer Set Programs} through
+Lua code.")))
+
+(define-public lua5.1-clingo (make-lua-clingo "lua5.1-clingo" lua-5.1))
+(define-public lua5.2-clingo (make-lua-clingo "lua5.2-clingo" lua-5.2))
+
 (define-public python-clingo
   (package
     (inherit clingo)