summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-09 17:47:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 22:03:27 +0100
commitf0862a357810895dd8759331daeebf9ee5b22d49 (patch)
treeb05f5a3eaa0e983a1e210c35c376454f7f85b3a7
parent6279d2b6dd1216573e51e25b4479820b81c01a54 (diff)
downloadguix-f0862a357810895dd8759331daeebf9ee5b22d49.tar.gz
gnu: Add r-fds.
* gnu/packages/cran.scm (r-fds): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5aa2b0d040..f7ecdfae4b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19411,6 +19411,31 @@ conditional on one covariate, and multimodal regression.")
 functional outliers with bagplots, boxplots and rainbow plots.")
     (license license:gpl3)))
 
+(define-public r-fds
+  (package
+    (name "r-fds")
+    (version "1.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "fds" version))
+       (sha256
+        (base32
+         "1284vncixrzrz9x6b52gslrbrbia07sd0xac7nwdqhp5f5v5wfi0"))))
+    (properties `((upstream-name . "fds")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rainbow" ,r-rainbow)
+       ("r-rcurl" ,r-rcurl)))
+    (home-page "https://cran.r-project.org/web/packages/fds/")
+    (synopsis "Functional data sets")
+    (description "This package contains a list of functional time series,
+sliced functional time series, and functional data sets.  Functional time
+series is a special type of functional data observed over time.  Sliced
+functional time series is a special type of functional time series with a time
+variable observed over time.")
+    (license license:gpl2+)))
+
 (define-public r-fda
   (package
     (name "r-fda")